Назад | Перейти на главную страницу

PowerShell - добавление нескольких строк к одному элементу массива

Так что у меня есть массив что мне нужно перебирать строку за строкой и разделять по интерфейсам. Мой код просматривает этот файл построчно. Я хочу разделить интерфейсы знаком "!" символ и добавить строки к элементу в массиве, чтобы я мог выполнить дальнейший анализ.

Вот как выглядит содержимое файла.

!
interface Loopback0
 description MANAGEMENT
 ip address 172.xxx.xxx.x
!
interface FastEthernet0/0
 description m<1> A<LAN on chr-city>
 no ip address
 ip flow ingress
 duplex auto
 speed auto
!
interface FastEthernet0/0.50
 description Management
 encapsulation dot1Q 50 native
 ip address 172.xxx.xxx.x
!
interface FastEthernet0/0.51
 description Transit
 encapsulation dot1Q 51
 ip address 172.xxx.xxx.x
 service-policy input mark
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
 description m<1> WAN<> V<CL> 
 bandwidth 1536
 ip address 172.xxx.xxx.x
 ip flow ingress
 no ip mroute-cache
 service-module t1 timeslots 1-24
 no cdp enable
 service-policy output shape
!
router bgp 65052

поиск по коду файла архива конфигурации

for ($m=0; $m -lt $configFileContents.length; $m++) {
     $index = 0
         if($configFileContents[$m] -eq "interface Loopback0"){ #starting spot
                $a = @()
                While($configFileContents[$m] -notmatch "router bgp") { #ending spot              
                       if($configFileContents[$m] -ne "!") { #divide the elements
                            $a[$index] += $configFileContents[$m] 
                         $m++
                        } else {
                                $index++
                                $m++
                           }
                 }

                Write-Host "interface archive section" -BackgroundColor Green
               $a
                Write-Host "end of interface archive section"  
         }`

Вопрос: Как добавить все строки интерфейса между "!" к одному элементу в моем массиве, а все последующие ко второму элементу и так далее?

Обновленный код

        $raw = [IO.File]::ReadAllText("$recentConfigFile")
        $myArr = @()
        $raw.Split("!") | % {$myArr += ,$_.Split("`n")}


        $i = 0
        $myArr | % {
            if ($_[0].Trim() -eq "interface Loopback0") {
                $start = $i
                } elseif ($_[0].Trim() -eq "router bgp 65052") {
                $end = $i
                }
            $i++
            }

        $myArr | Select-Object -Skip $start -First ($end-$start)

Вы слишком усердно работаете с петлями и условиями. Это должно дать вам массив с каждым элементом интерфейса как подмассив:

$raw = [IO.File]::ReadAllText("C:\Users\Public\Documents\Test\Config.txt")
$myArr = @()
$raw.Split("!") | % {$myArr += ,$_.Split("`n")}

Если все, что вам нужно, это каждый раздел интерфейса в виде строкового элемента, вы можете изменить последние две строки на это:

$myArr = $raw.Split("!")

После этого может потребоваться небольшая очистка массива, но это должно помочь вам на 99%. Например, чтобы получить только элементы между interface Loopback0 и router bgp 65052:

$i = 0
$myArr | % {
    if ($_[0] -like "*interface Loopback0*") {
        $start = $i
        } elseif ($_[0] -like "*router bgp 65052*") {
        $end = $i
        }
    $i++
    }

$myArr | Select-Object -Skip $start -First ($end-$start)

Первое разбиение на блоки

$x = Get-Content -Path 'D:\powershell\Files\input.txt' 
$x2 = $x -join "`r`n"
$x3 = $x2 -split "!`r`n"

коротко:

$x = @( $(@( Get-Content -Path 'D:\powershell\Files\input.txt'  ) -join "`r`n" ) -split "!`r`n" )

Затем вывод раскрашен

ForEach ($line in $x) {
    $local:lineArr = @( $line -split "`r`n" )
    $local:arrayInterfaces = @(  $local:lineArr | Where-Object {$_ -match '\s*interface\s'} )
    $local:arrayNonInterfaces = @( $local:lineArr | Where-Object { $local:arrayInterfaces -notcontains $_ } )

    Write-Host -ForegroundColor Red $( $local:arrayInterfaces -join "`r`n" )
    Write-Host -ForegroundColor Green $( $local:arrayNonInterfaces -join "`r`n" )
    Write-Host ( '#' * 60 )
}